Como resolver erro Ioncube Loader PHP em 5 passos

Se você está fazendo a instalação de um CMS ou sistema pronto, e você se depara com um erro do “Ioncube Loader”, isso se deve pois o código instalado está protegido pela criptografia Ioncube, e para executa-lo é necessário ativar o Ioncube Loader nas configurações do PHP.

Erro comum ao instalar o WHMCS, por exemplo:

“Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance.”

Caso você esteja utilizando uma hospedagem da HostMF, você poderá facilmente ativar o ioncube através de seu painel de controle (cPanel).

Ativando o Ioncube Loader (cPanel HostMF)

  1. Logue em seu cPanel
  2. Procure por “PHP”  e clique em “Selecionar PHP Versão”PHP Selector cpnale
  3. Note que a versão (nativa) pode estar selecionada. Você deve escolher qualquer versão, exceto a que está marcada como nativa.Alterar versão do PHP no CpanelPHP Selector
  4. Após escolher a versão, será necessário clicar em “Aplicar” para que a alteração seja aplicada.PHP Selector Extensions
  5. Após isso, você poderá marcar extensão “ioncube_loader”, e salvar as alterações.PHP Selector Ioncube Loader

Concluindo os passos acima, a sua hospedagem estará configurada com o ioncube loader e o erro não irá ocorrer novamente. Caso o problema ainda persista, certifique-se que a alteração foi de fato salva. Para ter certeza disso, atualize a página e verifique se as mudanças que foram feitas não foram perdidas.

Você poderá entrar em contato com o suporte da HostMF assim que for necessário. Atendemos via chat online, email e ticket. Não deixe de entrar em contato caso tenha alguma dúvida ou problema.

Deixe uma resposta